Author Topic: Photos manquantes dans la publication Site Web  (Read 2613 times)

0 Members and 1 Guest are viewing this topic.

Offline ClaudeP

  • VIP
  • Jr. Member
  • *
  • Posts: 13
    • View Profile
Photos manquantes dans la publication Site Web
« on: February 28, 2024, 23:09:58 »

Bonjour

J'ai un problème bizarre avec la publication "site web"

Je me suis rendu compte que des photos manquent, aussi bien à gauche sur la page initiale que sur la page détaillée de la personne
Bien sur, la photo est bien présente dans l'application

Pour résoudre le problème, il suffit, dans Ancestris de rentrer la même photo
Et lors de la génération suivante, pour cette photo, c'est bon

Mais quand on compare le fichier ged, après et avant cette opération, il n'y a aucune différence
Les lignes sont absolument les mêmes

Problème ;j'ai des dizaines de photos qui ne sont plus dans le site!
Donc pas évident de toutes les remettre

J'ai envisagé un pb de cache, mais je n'ai rien trouvé

Si quelqu'un a une idée ...

Version d'Ancestris :  11.0.10897
Java :  1.8.0_401-b10 - C:\Program Files\Java\jre-1.8
Système :  Windows 11 - 10.0 - claude
Répertoire utilisateur :  C:\Users\claude\.ancestris\11

Et la version de "Site web" est à jour

Claude





Online Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 3 978
    • View Profile
Re: Photos manquantes dans la publication Site Web
« Reply #1 on: February 29, 2024, 07:40:29 »
C'est d'autant plus étrange que comme vous utilisez la version 11, rien n'a bougé depuis la sortie de la version en 2021.

Est-ce que vos images sont sur votre PC ou sur un disque partagé ?

Zurga

Offline ClaudeP

  • VIP
  • Jr. Member
  • *
  • Posts: 13
    • View Profile
Re: Photos manquantes dans la publication Site Web
« Reply #2 on: February 29, 2024, 07:56:13 »
Bonjour

Tout a changé pour que rien ne change (si j'ose).

J'ai changé de portable, j'ai changé mon "serveur local" ou sont mes fichiers.
Du coup, tout est sur W11
Par contre, je ne sais pas quand ceci est arrivé!
Il y a deux ou six mois, aucune idée.

Mais, c'était bon, j'en suis sur. Ma femme fait parti des photos disparues.
Pas la mienne

Mais dans le fichier Ancestris, tous les noms de fichiers sont complets et tous ont le nom du nouveau serveur.
C'est pas beau, mais c'est plus simple.

Et aucune corrélation entre disparition et taille de la photo non plus.

Bizarre Bizarre.

Online Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 3 978
    • View Profile
Re: Photos manquantes dans la publication Site Web
« Reply #3 on: February 29, 2024, 08:17:35 »
Quand vous générez le site web sur votre ordinateur (avant de le mettre sue le serveur), est-ce que toutes les images s'affichent ?

Zurga

Offline ClaudeP

  • VIP
  • Jr. Member
  • *
  • Posts: 13
    • View Profile
Re: Photos manquantes dans la publication Site Web
« Reply #4 on: February 29, 2024, 10:33:46 »
Je génère le site web en local, puis je le transferts à distance

Bien sur le problème a lieu lors de la génération
Et pas vu de message d'erreurs, lors de la génération.

Offline ClaudeP

  • VIP
  • Jr. Member
  • *
  • Posts: 13
    • View Profile
Re: Photos manquantes dans la publication Site Web
« Reply #5 on: March 02, 2024, 07:38:00 »
J'ai trouvé !

C'est une conséquence indirecte de "ne pas publier pour les personnes vivantes"

Ayant changé d'ordinateur, ce paramètre était activé.

Et donc certaines personnes, a priori vivante, n'avaient plus leur photo.

C'est un peu aléatoire : ma photo était présente, et je pense être vivant.
En publiant les vivantes, toutes les photos manquantes reviennent.

Je pense néanmoins que le comportement photos/pas photos publier Vivantes/pas publier est, vu de l'extérieur, pseudo aléatoire.

Mais pour moi, c'est ok

Encore merci à toute l'équipe