Author Topic: Images dans le rapport "Complete graphical tree exported in yEd format"  (Read 337 times)

0 Members and 1 Guest are viewing this topic.

Offline renaud

  • VIP
  • Jr. Member
  • *
  • Posts: 6
    • View Profile
Bonjour à tous,

C'est probablement une question de débutant, mais après pas mal d'heures à chercher, je crois que j'ai besoin d'aide.

J'essaie d'exporter mon arbre sous forme d'un graphe lisible par yEd, à l'aide du rapport "Complete graphical tree exported in yEd format".
Le rapport fonctionne bien, mais les images d'identité n'apparaissent pas dans le rapport. Je précise qu'elles n'apparaissent pas du tout, même pas sous la forme d'une croix rouge pour signaler une image manquante, non, elles ne sont même pas dans les balises (le texte dans Général est de la forme <html><body>♀<p>DOE, John<br>° 14 Apr 1875 Châteaudouble<br></p></body></html>).

Je compare à ce que j’obtiens en exportant le rapport pour l'arbre d'exemple Bourbon, et celui-ci contient des références à des images (<html><table><tr><td>♂<p>CAPET, Louis XV<br>° 15 Feb 1710 Versailles<br>+ 10 May 1774 Versailles<br></p></td><td><img src="file:///C:/my documents/my images/photos/Louis_XV.jpg"></td></tr></table></body></html>).

J'ai cherché un peu plus, et les objets dans l'éditeur Gedcom semblent un peu différents (OBJE Multimedia dans mon arbre, OBJE File dans l'exemple).
Je ne comprend pas comment faire pour que ça fonctionne.

Merci pour votre aide, et désolé si c'est quelque chose que j'aurai loupé dans la documentation.

Bonne journée,
Renaud.

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 640
    • View Profile
Vous n'avez probablement rien loupé, mais on a peut-être loupé de notre côté la gestion des images lorsqu'elles ne sont pas embarquées dans l'individu.

On va jeter un oeil attentif.

Est-ce que vous pouvez essayer de mettre avec l'éditeur GEDCOM une image directement dans l'individu ?
Typiquement vous ajoutez une propriété OBJE et non pas une référence à une entité OBJE.

Zurga

Offline renaud

  • VIP
  • Jr. Member
  • *
  • Posts: 6
    • View Profile
Bonjour,

Merci pour votre réponse rapide. Effectivement ça fonctionne !
J'ai oublié de préciser que j'utilise Ancestris v11 (je préfère une version stable).

Il n'y a pas de risque particulier pour mon arbre à faire cette manipulation dans l’éditeur Gedcom je suppose ?

Merci encore pour votre aide,
Bien cordialement,

Renaud.

Offline ciprien

  • VIP
  • Newbie
  • *
  • Posts: 2
    • View Profile
Bonjour Renaud,

J'ai le même problème que vous; comment avez-vous procédé pour le régler ?
je n'arrive pas à mettre en oeuvre le conseil de Zurga.

Merci.

Alain

Offline renaud

  • VIP
  • Jr. Member
  • *
  • Posts: 6
    • View Profile
Bonjour Alain,

J'ai fait ce que proposait Zurga : depuis l'editeur Gedcom, clic droit sur la première ligne, là où il y a l'identifiant de la personne. Puis dans le menu contextuel Add property directly|Multimedia(OBJE).
Puis dans la section FILE de ce nouvel objet, j'ai sélectionné le fichier que je voulais utiliser.
Et là ça fonctionne.

C'est plus clair comme ça ?

Bien cordialement,
Renaud.



Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 640
    • View Profile
Après avoir vu le code, je confirme que le problème est dans Ancestris.
L'utilisation d'entité OBJE n'est pas prévue par ce rapport.

On va y remédier, mais ce sera dans la version 12.

Zurga

Offline ciprien

  • VIP
  • Newbie
  • *
  • Posts: 2
    • View Profile
Merci Renaud pour votre réponse;

Chez moi ça ne fonctionne pas, mais vu le commentaire de Zurga, je ne suis pas surpris.
Je vais attendre la correction dans la version 12.

Merci à tous les deux pour votre disponibilité.
C'est un vrai plaisir de communiquer avec vous.

Alain

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 640
    • View Profile
C'est corrigé.
Ce sera dans la version 12 demain.

Zurga