Author Topic: Object (Image) titles not displayed in editor  (Read 1455 times)

0 Members and 1 Guest are viewing this topic.

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Object (Image) titles not displayed in editor
« on: May 31, 2019, 13:46:11 »
For some reason, titles aren't being displayed in the editor even though they are present in the *.ged. This is the latest 'daily version' on Linux.





It's also almost impossible to resize columns in the grid to view the file path etc - the headers are incredibly unresponsive.

EDIT: I've also noticed that switching to the Aries editor tab when its gallery tab is selected from any other view causes a long delay. Switching between other tabs or to the Aries editor when its 'events' or some other tab is selected, does suffer from the delay. Switching between multimedia objects in the gallery view grid (with a single click) also causes a delay.

The path to the image also looks wrong in this grid - my files are shown as '/home/paul/desktop/../family-history-media/.... but /family-history/media is in my /home folder - I'm guessing that the first part of the displayed path is where the Ancestris folder is located and is being used to build a relative link to the image. The images themselves display correctly.

I have a lot of linked images, I wonder if all this path calculation is the cause of the delays?







« Last Edit: May 31, 2019, 13:59:03 by Paul »

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re: Object (Image) titles not displayed in editor
« Reply #1 on: May 31, 2019, 16:25:49 »
OK I think the issue with titles not appearing in the grid is because (in my *.ged) in some cases TITL is subordinate to FORM but in others it is the same level - probably a result of using different software over the years.

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 887
    • View Profile
Re: Object (Image) titles not displayed in editor
« Reply #2 on: May 31, 2019, 20:01:57 »
Ancestris open all files in memory.
If the files are large, you can have troubles with your memory.

You can change the max used memory in the ancestris.conf file.
Change the line default_options (line 12) and add more memory for the parameter "-J-Xmx1g" add more Giga on it (1g i for 1 giga).
To allow 4g, put -J-Xmx4g

Zurga

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re: Object (Image) titles not displayed in editor
« Reply #3 on: May 31, 2019, 20:22:35 »
Ancestris open all files in memory.
If the files are large, you can have troubles with your memory.

Edited ancestris.conf to allow up to 4gb but it doesn't make any difference. Switching between any view and Aries editor is fine except when Aries has gallery tab open - that results in a long delay.

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 887
    • View Profile
ReĀ : Object (Image) titles not displayed in editor
« Reply #4 on: June 03, 2019, 10:51:11 »
We will look at the gallery tab in Aries.
Not sure we can really improve the speed.

Zurga