Author Topic: [Résolu] Outils > Préférences ne fonctionne pas  (Read 217 times)

0 Members and 1 Guest are viewing this topic.

Offline yinyang

  • VIP
  • Full Member
  • *
  • Posts: 11
    • View Profile
[Résolu] Outils > Préférences ne fonctionne pas
« on: June 06, 2019, 16:20:42 »
Bonjour à toutes et à tous,
Lorsque je clique sur "Préférences", il ne se passe rien.
Je suppose qu'une fenêtre doit s'ouvrir pour proposer des options à choisir.

Je viens de lire sur l'aide qu'on peut accéder aux Préférences par la roue dentée bleue à droite de la barre d'outils: idem
« Last Edit: June 08, 2019, 15:40:42 by yinyang »
0.10.0.9841 sur Linux Mint 19

Offline Zurga

  • VIP
  • Hero Member
  • *
  • Posts: 253
    • View Profile
Re : Outils > Préférences ne fonctionne pas
« Reply #1 on: June 06, 2019, 17:20:20 »
Bonjour,

Avez-vous une indication d'erreur quelque part ?
Normalement, Outils => Préférences affiche une joli fenêtre qui ressemble à l'image jointe.

Zurga

Offline yinyang

  • VIP
  • Full Member
  • *
  • Posts: 11
    • View Profile
Re: Outils > Préférences ne fonctionne pas
« Reply #2 on: June 07, 2019, 14:42:43 »
Bonjour Zurga
Je découvre Ancestris, donc mes connaissances sur cette application sont rudimentaires (pareil pour java) !
En cliquant à nouveau sur Préférences, j'ai vu un petit logo tout en bas à droite devenir rouge.
J'ai obtenu la fenêtre voir fichier "Préférences_KO"
J'ai ouvert un fichier log
Je n'y ai rien rien compris, à part qu'il y a l'air d'y avoir pas mal d'erreurs (WARNING, SEVERE)
Toutefois, au début je lis :
Java; VM; Vendor        = 11.0.3; OpenJDK 64-Bit Server VM 11.0.3+7-Ubuntu-1ubuntu218.04.1; Oracle Corporation
  Runtime                 = OpenJDK Runtime Environment 11.0.3+7-Ubuntu-1ubuntu218.04.1
  Java Home               = /usr/lib/jvm/java-11-openjdk-amd64

Il me semble qu'il fallait java 8 que j'avais pourtant indiqué.
Sinon :
WARNING [org.openide.filesystems.Ordering]: Found same position 800 for both Toolbars/Nav and Toolbars/Standard.xml
INFO [org.netbeans.ui.metrics.laf]: USG_LOOK_AND_FEEL
SEVERE [global]
java.lang.ClassNotFoundException: javax.activation.DataContentHandlerFactory
   at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
   at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
   at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
   at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:222)
Caused: java.lang.ClassNotFoundException: javax.activation.DataContentHandlerFactory starting from ModuleCL@2469bc43[org.openide.awt] with possible defining loaders null and declared parents [org.netbeans.MainImpl$BootClassLoader@5ce65a89, ModuleCL@585be10a[org.netbeans.api.annotations.common]]

Peut-être cela pourra-t-il vous éclairer ?
Merci déjà pour votre attention
0.10.0.9841 sur Linux Mint 19

Offline Zurga

  • VIP
  • Hero Member
  • *
  • Posts: 253
    • View Profile
Re : Outils > Préférences ne fonctionne pas
« Reply #3 on: June 07, 2019, 15:06:23 »
Le problème vient de votre version de Java.

Ancestris ne fonctionne qu'avec la version 8 de Java comme indiqué dans la documentation :
https://fr.ancestris.org/index.php?title=Installation#Pr.C3.A9requis_Java

Une fois que vous aurez installé une version 8 de Java, tout devrait rentrer dans l'ordre.

Vous pouvez spécifier le JDK en allant dans ancestris/etc/ancestris.conf


Zurga

« Last Edit: June 07, 2019, 15:15:52 by Zurga »

Offline yinyang

  • VIP
  • Full Member
  • *
  • Posts: 11
    • View Profile
Re: Outils > Préférences ne fonctionne pas
« Reply #4 on: June 07, 2019, 16:37:30 »
Zurga
Je venais de trouver !
J'ai un autre portable sur lequel je voyais la fenêtre Préférences.
J'ai cherché dans mon mémo Linux (je n'y connais rien non plus) et avec sudo update-alternatives --config java, j'ai vu comment changer ma version 11 en 8.
Et ça y est, je vois Préférences.
Merci à nouveau

P.S. Est-ce qu'un jour la version 8 de java ne sera pas un jour obsolète et plus maintenue ou trouvable ?
Est-ce que cela ne fragilise pas la vie d'Ancestris ?
Ou, est-ce que Ancestris ne basculera pas un jour sur java 11 (ou suivra java au fur et à mesure de ses updates ?
« Last Edit: June 07, 2019, 16:46:19 by yinyang »
0.10.0.9841 sur Linux Mint 19

Offline Zurga

  • VIP
  • Hero Member
  • *
  • Posts: 253
    • View Profile
Re: Outils > Préférences ne fonctionne pas
« Reply #5 on: June 07, 2019, 20:57:15 »
Ancestris va évoluer pour fonctionner avec d'autres versions de Java, mais actuellement, il y a encore du travail pour en faire une version totalement compatible (vous en avez eu un aperçu).
On y travaille....

Zurga

Offline yinyang

  • VIP
  • Full Member
  • *
  • Posts: 11
    • View Profile
Re: Outils > Préférences ne fonctionne pas
« Reply #6 on: June 08, 2019, 13:34:16 »
Merci déjà pour ce qui a déjà été fait (je suppose que vous faites partie de l'équipe de développement) et bon courage pour la suite.

P.S. je viens de lire le fichier conf, il m'est hermétique. A part 3 lignes toutes les autres commencent par # donc ce doivent être des commentaires. Je vais lire la documentation (importante) pour essayer de trouver des éléments si j'en ai besoin un jour.
« Last Edit: June 08, 2019, 13:44:06 by yinyang »
0.10.0.9841 sur Linux Mint 19