Author Topic: Ancestris sur Mac OSX  (Read 388 times)

0 Members and 1 Guest are viewing this topic.

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Ancestris sur Mac OSX
« on: January 26, 2018, 16:35:05 »
Bonjour à tous
Je ne suis pas très fort en généalogie mais, surtout, je suis nul en informatique.
J'ai installé Java (version 8 Update 161). J'ai téléchargé Ancestris pour Mac OSX, permis à l'ordi de l'installer (coché "n'importe où" puisque "développeurs identifiés" n'a pas fonctionné).
Quand je veux ouvrir Ancestris, il se referme au bout d'une dizaine de secondes sans message d'erreur.
Qu'ai-je oublié?
Merci de vos réponses.

Offline Jean-Roger

  • VIP
  • Full Member
  • *
  • Posts: 23
    • View Profile
Re : Ancestris sur Mac OSX
« Reply #1 on: January 27, 2018, 09:03:15 »
Bonjour,


Celà ressemble à une incompatibilé de version entre Ancestris et MacOs.
Mais pour une réponse utile, il manque quelques petites infos sur votre message :
- quel mac utilisez-vous ?
- quelle version de MacOs
- quelle version d'Ancestris, quel installateur (dmg ou zip)
- quel Java (JDK ou JRE)


Mais félicitation, vous avez fait les bons choix  ;)


Cordialement
Jean-Roger

Version Ancestris : 0.10.0.9695
Java : 1.8.0_162-b12 - /Library/Java/JavaVirtualMachines/jdk1.8.0_162.jdk/Contents/Home/jre
Système : Mac OS X - 10.13.6

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re: Ancestris sur Mac OSX
« Reply #2 on: January 27, 2018, 13:30:10 »
Bonjour

mac: iMac mi-2011
MacOs: OS X Yosemite
Ancestris: osx_0.9_0_20161221 zip ( en fait, celui qui est proposé sur la page de téléchargement)
Java: jre-8u161-macosx-x64 dmg

J'ai un peu l'impression d'écrire dans une langue étrangère mais j'espère qu'à vous, ça vous parle.

En tous cas, merci d'avoir pris en compte mon message.

Offline Jean-Roger

  • VIP
  • Full Member
  • *
  • Posts: 23
    • View Profile
Re : Ancestris sur Mac OSX
« Reply #3 on: January 27, 2018, 15:08:51 »
Java: jre-8u161-macosx-x64 dmg

Bizarre. Je viens d'essayer les deux ZIP (celui spécifique à Mac et l'autre en dessous), ils fonctionnent parfaitement chez moi.
Une question sur la ligne Java : vous citez le fichier d'installation (.dmg). Avez-vous bien exécuté ce fichier avant de lancer Ancestris ?
Jean-Roger

Version Ancestris : 0.10.0.9695
Java : 1.8.0_162-b12 - /Library/Java/JavaVirtualMachines/jdk1.8.0_162.jdk/Contents/Home/jre
Système : Mac OS X - 10.13.6

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re: Ancestris sur Mac OSX
« Reply #4 on: January 27, 2018, 16:20:59 »
Oui. Du moins, je pense. Pour ne pas vous dire de bêtises, je viens de réouvrir le fichier. Donc, tout le processus s'est fait au niveau installation jusqu'au message final qui indique que la fermeture de la fenêtre fait basculer sur le site d'Oracle. Lequel m'a bien confirmé que Java était bien installé et qui recommande de redémarrer l'ordinateur. Ce que je viens de faire. Le résultat est le même: quand je lance Ancestris, l'application s'arrête au bout de quelques secondes.
Par contre, pour reprendre vos termes, à aucun moment je n'ai de fenêtre qui me propose "d'éxécuter" le fichier d'installation.

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 471
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re : Ancestris sur Mac OSX
« Reply #5 on: January 27, 2018, 17:50:51 »
Bonjour, je pense qu'il faudrait prendre la version beta 0.10 au format .zip sur le trac
Frédéric avait corrigé des choses pour mac il me semble. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re: Ancestris sur Mac OSX
« Reply #6 on: January 27, 2018, 18:12:20 »
Bonjour

Je mets la version Mac à la corbeille avant de télécharger la version beta?

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 471
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re: Ancestris sur Mac OSX
« Reply #7 on: January 27, 2018, 18:19:41 »
Bonsoir. Je ne connais pas MacOs, mais je dirais oui, à priori, ça ne sert à rien de garder les deux versions qui pourraient se géner l'une l'autre. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re: Ancestris sur Mac OSX
« Reply #8 on: January 27, 2018, 18:25:15 »
Bon: c'est parti!
Je ne suis plus à un essai près!!!

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re : Ancestris sur Mac OSX
« Reply #9 on: January 27, 2018, 18:57:22 »
Mauvaise pioche: ça n'a pas marché.
Vu qu'il faut positiver: 1: l'icône de Java est apparue quelques secondes dans la barre des tâches
                                 2: il y a eu un message d'erreur que je mets en pièce jointe

deux choses que je n'avais pas eu jusqu'à présent: donc je considère que ça avance!!!!

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 471
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re : Ancestris sur Mac OSX
« Reply #10 on: January 27, 2018, 19:00:12 »
Si vous avez un peu de temps, venez donc sur l'IRC. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 471
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re : Ancestris sur Mac OSX
« Reply #11 on: January 28, 2018, 19:38:44 »
Bonsoir,
Si j'ai bien compris, c'est parce que vous utilisiez java 1.9 au lieu de java 1.8. A l'heure où j'écris ce message, Ancestris a besoin de java 1.8, il ne fonctionne pas avec java 1.9. Dans l'avenir bien sûr il sera développé pour fonctionner avec les futures versions de java. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline jj69800

  • VIP
  • Full Member
  • *
  • Posts: 14
    • View Profile
Re : Ancestris sur Mac OSX
« Reply #12 on: January 28, 2018, 19:51:53 »
Bonsoir François
 
Je ne sais pas trop. A priori, il y avait du java 1.9 dans l'ordi puisqu'on en a retrouvé des traces dans la librairie système alors que, lors des différents essais que j'ai fait, il ne m'a toujours été proposé que le 1.8.
Peu importe: l'essentiel est que ça fonctionne!!
Je suis en pleine découverte.

Encore un grand merci à vous deux!
C'est tellement mieux quand il y a des êtres vivants derrière un logiciel.