Ancestris Support > ENGLISH

MacOs compatibility

(1/6) > >>

I run Mojave OS on my iMac. I have downloaded both Ancestris 11 and 12 for MacOs and I can't get either one to open. I read a topic here about java being important to this software being able to run on Macs. If so what old versions of Ancestris will work or alternatively which version of Java do I need. I'm not an expert on Mac software configuration so keep it simple! Thank you.

You have to install Jave on your Mac.
Ancestris works from Java 8 to Java 21 (Java 17 is recommended).
After you should be able to run Ancestris.

The documentation step by step is here :


Thanks for your reply Zurga, Ancestris now works. I have an iMac and I started with Java 21 but it did not work. i found out on Youtube how to remove it using Terminal. I then installed 17 according to your documentation link and all is now well. Many thanks.   

Good news.

I hope the software will fill your needs.
Don't hesitate to ask if you have others questions.



I am trying to run Ancestris 12 on Sonoma 14.4.1 but with java installed using sdkman ( - as a java developper I often need to switch the java version

Running java -version gives
openjdk version "17.0.11" 2024-04-16 LTS
OpenJDK Runtime Environment Corretto- (build 17.0.11+9-LTS)
OpenJDK 64-Bit Server VM Corretto- (build 17.0.11+9-LTS, mixed mode, sharing)

Java SDK is available at the following location : ${SDKMAN_DIR}/candidates/java/current

When I start Ancestris I get the error message

--- Quote ---JAVA is missing or not found. Ancestris requires JAVA.

Please install JAVA version 8, 11 or 17. Feel free to follow the Ancestris instructions in the online
--- End quote ---

-> I tried to export the variable jdkhome before starting the App but same error message ?
-> I tried to define a local config file under .ancestris/trunk/etc but same error message

Any idea ?



[0] Message Index

[#] Next page

Go to full version