Author Topic: Welke versie van Ancestris moet ik gebruiken?  (Read 2498 times)

0 Members and 1 Guest are viewing this topic.

Offline mother10

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 180
  • Never give up trying to get what you really want!
    • View Profile
    • Motherware
Welke versie van Ancestris moet ik gebruiken?
« on: November 09, 2023, 07:14:52 »
Hallo Allemaal,

Ancestris komt altijd in 2 versies, beide zijn beschikbaar voor diverse systemen.

Welke versie moet ik nu gebruiken?

Voor het antwoord is allereerst het volgende belangrijk:

De versie met het laagste nummer (dat is op dit moment versie 11) is "officieel" gereleased.
Dat betekent dat die versie ten eerste, zichzelf installeert, compleet met de benodigde Java.
Ten tweede dat deze versie is afgesloten voor verdere uitbreiding.
NIET voor het oplossen van eventuele fouten die de werking ervan geheel zouden verstoren, maar WEL voor verdere uitbreiding met nieuwe functies.

De versie met het hoogste nummer (dat is op dit moment versie 12) is de versie "die in ontwikkeling is".
Deze versie is (nog niet) officieel gereleased, maar bevat wel ALLE nieuwe ontwikkelingen en uitbreidingen.
Deze versie installeert zich niet zelf, maar moet worden geïnstalleerd zoals hier beschreven:
https://docs.ancestris.org/books/gebruikershandleiding/page/stap-voor-stap-installatie-van-de-dagelijkse-versie-op-windows-bv-versie-12

Het volgende belangrijke punt is:
Aangezien wensen van gebruikers, verbeteringen van bestaande functies, geheel nieuwe functies en dergelijke, alleen maar in de nieuwste versie beschikbaar zijn, is het aan te raden de laatste (nog niet officiële) versie van Ancestris te gebruiken.
Dit geldt vooral als de releasedatum van de "oude versie" (zie voor de release datum ervan: https://forum.ancestris.org/index.php?board=12.0 ) ver weg ligt van de huidige datum.

Maar is dat dan niet gevaarlijk, want die is niet "officiëel"?

Nee, dat is niet gevaarlijk. De ontwikkelaars testen elke wijziging uitvoerig voor deze wordt vrijgegeven in een dagelijkse update.
En Ancestris is zodanig gebouwd dat de kans op een totale crash, uiterst minimaal is.
Als ik voor mezelf spreek: Ik werk nu al sinds ongeveer november 2022 met versie 12, dus al een jaar, (op dit moment dus de versie die in ontwikkeling is), er zijn al ontzettend veel aanpassingen aan deze versie 12 gedaan in al die tijd, en ik heb nog niet meegemaakt dat deze versie is gecrashed, of onoverkomelijke problemen gaf.

Het grote voordeel van de versie in ontwikkeling is, dat deze geheel up to date is.
Als ik versie 12 nu vergelijk met versie 11, dan zitten in versie 12 zoveel nieuwe dingen en verbeteringen, dat versie 11, op dit moment, hopeloos ouderwets lijkt, vergeleken met versie 12.

Ja, de versie in ontwikkeling is misschien ietsje lastiger te installeren, vandaar ook de uitgebreide beschrijving hiervoor, zoals hierboven genoemd, maar dat weegt met gemak op tegen al het nieuwe dat daarin te vinden is.
En als u toch een beetje huiverig bent om nu al over te stappen op deze ontwikkel versie, dan maakt u toch gewoon een backup van uw gegevens, vóór u overstapt.

En nogmaals, zoals her en der al is gezegd, VRAAG HET HIER, ALS IETS NIET LUKKEN WIL !!!

Groetjes,
Tineke
Vergeet niet naar de originele  Ancestris hoofdpagina te gaan, en heel belangrijk: Lees de  Documentatie !!!