Author Topic: Installation sur Debian 12 [Résolu]  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

Offline galinette

  • VIP
  • Jr. Member
  • *
  • Posts: 7
    • View Profile
Installation sur Debian 12 [Résolu]
« on: September 23, 2023, 19:05:18 »
Bonsoir,
ayant du réinstaller mon système debian (mon ancien PC m'a lâché), je suis obligé de réinstaller ancestris sur ma debian 12. Problème le paquet "ancestris_11-20211017.deb" ne peut pas s'installer avec le message d'erreur suivant :
Code: [Select]
Les paquets suivants contiennent des dépendances non satisfaites :
 ancestris : Dépend: sun-java8-jdk mais il n'est pas installable ou
                      sun-java8-jre mais il n'est pas installable ou
                      openjdk-8-jre mais il n'est pas installable ou
                      openjdk-8-jdk mais il n'est pas installable ou
                      sun-java9-jdk mais il n'est pas installable ou
                      sun-java9-jre mais il n'est pas installable ou
                      openjdk-9-jre mais il n'est pas installable ou
                      openjdk-9-jdk mais il n'est pas installable ou
                      sun-java10-jdk mais il n'est pas installable ou
                      sun-java10-jre mais il n'est pas installable ou
                      openjdk-10-jre mais il n'est pas installable ou
                      openjdk-10-jdk mais il n'est pas installable ou
                      sun-java11-jdk mais il n'est pas installable ou
                      sun-java11-jre mais il n'est pas installable ou
                      openjdk-11-jre mais il n'est pas installable ou
                      openjdk-11-jdk mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Pourtant sur mon ancien système c'était passé nickel.
Merci pour vos lumières
Michel
PS : java est bien installé en version 17
« Last Edit: September 25, 2023, 15:03:47 by galinette »

Offline FredericL

  • VIP
  • Hero Member
  • *
  • Posts: 715
    • View Profile
    • Généalogie personnelle et logiciel gratuit Ancestris
Re: Installation sur Debian 12
« Reply #1 on: September 23, 2023, 19:49:56 »
Bonjour,

Essayez avec Ancestris v12 à partir du fichier ZIP, pas du fichier 'deb'.

Bien cordialement,
Frédéric
« Last Edit: September 23, 2023, 19:54:21 by FredericL »

Offline cartes34

  • VIP
  • Full Member
  • *
  • Posts: 39
    • View Profile
Re : Installation sur Debian 12
« Reply #2 on: September 24, 2023, 13:30:33 »
Bonjour,

Vous pouvez aussi récupérer le deb de la version 12 à partir du ppa d'ancestris

https://launchpad.net/~ancestris/+archive/ubuntu/ancestris-unstable/+packages

Offline galinette

  • VIP
  • Jr. Member
  • *
  • Posts: 7
    • View Profile
Re: Installation sur Debian 12
« Reply #3 on: September 25, 2023, 15:03:01 »
Bonjour à tous,
je n'ai pas compris ce qui bloque avec le .deb et comme sur la debian 12 c'est toute une galère d'installer des ppa, en copiant le .zip j'arrive à lancer Ancestris et c'est avant tout ce qui m'importe en la matière.
Merci pour vos conseils.
Bien à vous.
Michel

Offline daucourt

  • VIP
  • Jr. Member
  • *
  • Posts: 14
    • View Profile
Re: Installation sur Debian 12 [Résolu]
« Reply #4 on: November 04, 2023, 21:50:42 »
Bonjour à tous,

J'ai réinstallé mon PC, et du coup je suis passé en debian 12 bookworm.
J'ai eu le même souci que galinette : le .deb demande une version 8, 9, 10 ou 11 de java, alors que l'on ne peut plus descendre en dessous de java 17.
L'installation du .deb émet un message d'erreur. Mais cela ne bloque pas l'installation. Et ce qui est surprenant, c'est que c'est quand même installé, et cela fonctionne avec java 17 !

Comme je préfère fonctionner en version "stable", je crois que je vais me contenter de cela.

Merci encore à toute l'équipe pour ce formidable logiciel non privatif.

Offline daucourt

  • VIP
  • Jr. Member
  • *
  • Posts: 14
    • View Profile
Re : Installation sur Debian 12 [Résolu]
« Reply #5 on: November 05, 2023, 16:58:46 »
Alors, ancestris fonctionne correctement, mais apt non. Ce dernier me demande de désinstaller le paquet cassé. Du coup je me suis rabattu sur le .deb d'ubuntu jammy.

Offline cartes34

  • VIP
  • Full Member
  • *
  • Posts: 39
    • View Profile
Re: Installation sur Debian 12 [Résolu]
« Reply #6 on: November 05, 2023, 18:35:45 »
Bonjour,

Effectivement la version dites stable impose ces versions de Java, ce qui pose problème avec Debian 12 sorti il y a quelques mois.
La solution possible serait de passer à ancestris 12 qui n'a d'instable que le nom mais reste la version en cours. C'est vraiment la solution préconiser car cette version régle plusieurs problèmes.

Dans l'absolu il y aurait deux autres solutions :

- modifier le paquet deb du site pour mettre Java 11 en dépendance.
- sortir ancestris 12 en version dites stable.

Bien à vous

Philippe