Author Topic: Font nécessaire avec Linux  (Read 1211 times)

0 Members and 1 Guest are viewing this topic.

Offline kristen

  • VIP
  • Full Member
  • *
  • Posts: 20
    • View Profile
Re: Font nécessaire avec Linux
« Reply #15 on: January 15, 2022, 12:17:03 »
Merci pour ton retour Creusois ;)

Offline yannig

  • VIP
  • Hero Member
  • *
  • Posts: 153
  • Yannick VOYEAUD
    • View Profile
    • Généalogie et histoire
Re : Font nécessaire avec Linux
« Reply #16 on: January 15, 2022, 17:26:15 »
@zurga
Ce n'est pas le java officiel mais OpenJDK installé via Synaptic le gestionnaire de paquets ou en direct via Aptitude par un copain.
Via Synaptic j'ai des versions jusqu'à 17

Amitiés
Yannick VOYEAUD
https://voyeaud.org
Debian 11
Ancestris 12

Offline fladnag

  • VIP
  • Jr. Member
  • *
  • Posts: 11
    • View Profile
Re : Font nécessaire avec Linux
« Reply #17 on: January 17, 2022, 08:51:06 »
Au cas ou ca puisse aider... pour améliorer la pixelisation sur une application Java d'un autre projet, on utilise ces paramètres au démarrage (a adapter avec le "-J" supplémentaire apparemment pour Ancestris) :

Code: [Select]
-Dremote.x11.workaround=false
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Djava2d.font.loadFontConf=true
-Dsun.java2d.xrender=false
-Dcom.sun.awt.use.national.layouts=true

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 701
    • View Profile
Re : Re : Font nécessaire avec Linux
« Reply #18 on: January 17, 2022, 08:52:54 »
(a adapter avec le "-J" supplémentaire apparemment pour Ancestris)
Ce n'est pas tant Ancestris que Netbeans qui a besoin du modificateur -J pour indiquer qu'il faut passer le paramètre à la JVM et pas le garder pour lui.

Zurga

Offline kristen

  • VIP
  • Full Member
  • *
  • Posts: 20
    • View Profile
Re: Re : Font nécessaire avec Linux
« Reply #19 on: January 17, 2022, 12:28:33 »
Au cas ou ca puisse aider... pour améliorer la pixelisation sur une application Java d'un autre projet, on utilise ces paramètres au démarrage (a adapter avec le "-J" supplémentaire apparemment pour Ancestris) :

Code: [Select]
-Dremote.x11.workaround=false
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Djava2d.font.loadFontConf=true
-Dsun.java2d.xrender=false
-Dcom.sun.awt.use.national.layouts=true
Bonjour
Je ne sais pas où mettre toutes ces lignes :-(

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 701
    • View Profile
Re: Font nécessaire avec Linux
« Reply #20 on: January 17, 2022, 15:04:13 »
Au même endroit que le paramètre que j'ai indiqué.

Vous devriez avoir dans votre fichier ancestris.conf quelque chose qui ressemble à cela :
Code: [Select]
default_options="--branding ancestris -J-Xms96m -J-Xmx1g --laf javax.swing.plaf.nimbus.NimbusLookAndFeel -J-XX:+IgnoreUnrecognizedVMOptions -J-XX:+UseStringDeduplication -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.zip.disableMemoryMapping=true -J--add-opens=java.base/java.net=ALL-UNNAMED -J--add-opens=java.base/java.lang.ref=ALL-UNNAMED -J--add-opens=java.base/java.lang=ALL-UNNAMED  -J--add-opens=java.base/java.util=ALL-UNNAMED -J--add-exports=java.base/sun.reflect.annotation=ALL-UNNAMED -J--add-opens=java.prefs/java.util.prefs=ALL-UNNAMED -J--add-exports=java.management/sun.management=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.text=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.plaf.synth=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.plaf.basic=ALL-UNNAMED -J--add-opens=java.desktop/java.awt=ALL-UNNAMED -J--add-opens=java.desktop/java.awt.event=ALL-UNNAMED -J--add-exports=java.desktop/java.awt.peer=ALL-UNNAMED -J--add-exports=java.desktop/com.sun.beans.editors=ALL-UNNAMED -J--add-exports=java.desktop/sun.swing=ALL-UNNAMED -J--add-exports=java.desktop/sun.awt=ALL-UNNAMED -J--add-exports=java.desktop/sun.awt.im=ALL-UNNAMED -J--add-opens=java.desktop/sun.awt.X11=ALL-UNNAMED -J--add-opens=java.desktop/sun.awt.shell=ALL-UNNAMED -J--add-opens=java.desktop/com.sun.java.swing.plaf.gtk=ALL-UNNAMED -J--add-opens=java.desktop/com.sun.java.swing.plaf.motif=ALL-UNNAMED"
Il faut le remplacer par :
Code: [Select]
default_options="-J-Dremote.x11.workaround=false -J-Dawt.useSystemAAFontSettings=lcd -J-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine -J-Djava2d.font.loadFontConf=true -J-Dsun.java2d.xrender=false -J-Dcom.sun.awt.use.national.layouts=true --branding ancestris -J-Xms96m -J-Xmx1g --laf javax.swing.plaf.nimbus.NimbusLookAndFeel -J-XX:+IgnoreUnrecognizedVMOptions -J-XX:+UseStringDeduplication -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.zip.disableMemoryMapping=true -J--add-opens=java.base/java.net=ALL-UNNAMED -J--add-opens=java.base/java.lang.ref=ALL-UNNAMED -J--add-opens=java.base/java.lang=ALL-UNNAMED  -J--add-opens=java.base/java.util=ALL-UNNAMED -J--add-exports=java.base/sun.reflect.annotation=ALL-UNNAMED -J--add-opens=java.prefs/java.util.prefs=ALL-UNNAMED -J--add-exports=java.management/sun.management=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.text=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.plaf.synth=ALL-UNNAMED -J--add-opens=java.desktop/javax.swing.plaf.basic=ALL-UNNAMED -J--add-opens=java.desktop/java.awt=ALL-UNNAMED -J--add-opens=java.desktop/java.awt.event=ALL-UNNAMED -J--add-exports=java.desktop/java.awt.peer=ALL-UNNAMED -J--add-exports=java.desktop/com.sun.beans.editors=ALL-UNNAMED -J--add-exports=java.desktop/sun.swing=ALL-UNNAMED -J--add-exports=java.desktop/sun.awt=ALL-UNNAMED -J--add-exports=java.desktop/sun.awt.im=ALL-UNNAMED -J--add-opens=java.desktop/sun.awt.X11=ALL-UNNAMED -J--add-opens=java.desktop/sun.awt.shell=ALL-UNNAMED -J--add-opens=java.desktop/com.sun.java.swing.plaf.gtk=ALL-UNNAMED -J--add-opens=java.desktop/com.sun.java.swing.plaf.motif=ALL-UNNAMED"
J'ai mis tous les paramètres au début des options car la ligne est longue.

Zurga


Offline kristen

  • VIP
  • Full Member
  • *
  • Posts: 20
    • View Profile
Re: Font nécessaire avec Linux
« Reply #21 on: January 18, 2022, 06:33:14 »
Bon je ne vois pas de changement. Sur OpenSUSE et sur Linux Mint, l'affichage est correct donc le problème vient de debian. Manquement d'un paquet peut-être ? Ou problème de KDE Plasma ou bug ?
Je me demande si je ne vais pas passer cette machine sous OpenSUSE vu que je suis très content de cette distribution !