Author Topic: Font sizes  (Read 2191 times)

0 Members and 1 Guest are viewing this topic.

Offline exminer

  • VIP
  • Newbie
  • *
  • Posts: 4
    • View Profile
Font sizes
« on: June 03, 2019, 04:44:20 »
When I open a gedcom file in Ancestris I find all of the text in every window is too small for my tired old eyes. I can't find how to fix this problem. Is there a way to increase the size of the font Ancesttis uses?

Thanks.

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re: Font sizes
« Reply #1 on: June 03, 2019, 09:40:13 »
I've tried to find a solution to this too but without success, hopefully an answer will be forthcoming. The font is not only small but isn't smoothed so is unpleasant to look at. Seems odd that we can set output font but not interface font.

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 709
    • View Profile
Re: Font sizes
« Reply #2 on: June 03, 2019, 10:48:12 »
Hi,

Ancestris is based on Netbeans (basically, this is a bunch of Netbeans plugins), so we inherit of the standard behavior of Netbeans, including fonts definition.
By default, Ancestris use the value of your system.
If you change your global font settings, it should change the one used in Ancestris.

Nevertheless, I finally find a way to change the size of the font by changing the ancestris.conf file.

Go to the ancestris/etc directory, open the ancestris.conf file and add to the line "default_options" the parameter : "--fontsize 24" (the value 24 is given as example, you can choose the one you want, the default value is 11).
Restart Ancestris and you should see the difference.
Warning : I don't have tested extensively this option. It could lead to cut texts and random effect on windows display.

Zurga
« Last Edit: June 03, 2019, 12:27:19 by Zurga »

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re : Re: Font sizes
« Reply #3 on: June 03, 2019, 19:59:20 »
Go to the ancestris/etc directory, open the ancestris.conf file and add to the line "default_options" the parameter : "--fontsize 24" (the value 24 is given as example, you can choose the one you want, the default value is 11).
Restart Ancestris and you should see the difference.
Warning : I don't have tested extensively this option. It could lead to cut texts and random effect on windows display.

Thanks for the suggestion but it doesn't seem to work, whatever font size I choose. The relevant line in my ancestris.conf reads:
Code: [Select]
default_options="--branding ancestris -J-Xms96m --J-Xmx4g --laf Nimbus --fontsize 18"

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 709
    • View Profile
Re : Font sizes
« Reply #4 on: June 03, 2019, 22:15:20 »
So you should have another conf file in .ancestris/trunk/etc

Here is size 36 example

Zurga

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re: Re : Font sizes
« Reply #5 on: June 04, 2019, 08:10:05 »
So you should have another conf file in .ancestris/trunk/etc

Yes, I can confirm that the font size is changed when the option is added to that file. However, as you suspected, it messes up the interface in places:

« Last Edit: June 04, 2019, 08:13:23 by Paul »

Offline Zurga

  • VIP
  • Supernatural Member
  • *
  • Posts: 2 709
    • View Profile
Re : Font sizes
« Reply #6 on: June 04, 2019, 09:52:26 »
We will try to fix display, but I can't give you assurance this will be done quickly.

The standard value is 11. If you can stay close to this value (12 or 14) it should be almost right.

Zurga

Offline Paul

  • VIP
  • Sr. Member
  • *
  • Posts: 97
    • View Profile
Re: Font sizes
« Reply #7 on: June 04, 2019, 10:27:59 »
Thanks for that, a font size of 14 is more than big enough for me on a wide-screen display and it doesn't cause any issues that I can see. :D