Author Topic: Java  (Read 62 times)

0 Members and 1 Guest are viewing this topic.

Offline patraf

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Java
« on: July 27, 2020, 17:57:34 »
Bonjour,
Le point sur Java dans la documentation n'est pas clair.

J'utilise Windows 10 64 bit français.

Il existe deux paquetages Java actuels: JDK (development kit), version 14, et JRE (runtime environment), version 1.8.0
Lequel est nécessaire ? Le JDK sembnle nécessiter une inscription chez Oracle…

Et dans le fichier ancestris.conf, la ligne jdkhome doit pointer sur quoi ? Le répertoire bin ? Chez moi il ne contient que le répertoire server qui contient classes.jsa.

Suite à une incitation à mettre à jour ma version de java et à détruire les anciennes versions par souci de sécurité, Ancestris ne se lance plus.
Le répertoire JRE ne contient plus que lib/fonts…

Je trouverais utile d'avoir une documentation plus précise: quels fichiers sont nécessaires, quelles variables d'environnement ?

L'exemple de commande java -version de la doc d'Ancestris indique en 3e ligne un Java HotSpot Server VM; chez moi j'ai un Client VM: est-ce bon quand même ?

Désolé, je ne suis pas du tout connaisseur en java.

Offline FredericL

  • VIP
  • Hero Member
  • *
  • Posts: 243
    • View Profile
    • Généalogie personnelle et logiciel gratuit Ancestris
Re: Java
« Reply #1 on: July 27, 2020, 18:43:43 »
Bonjour,

On a pourtant passé pas mal de temps sur la documentation de cette page.

Si votre besoin est juste d'installer java pour faire fonctionner Ancestris, suivre la doc devrait suffire.

Manifestement vous vous posez beaucoup de questions, du coup je me demande si vous voulez aussi une leçon complète sur java auquel cas java a sa propre doc.

En fait, quel est le problème ?

Merci.

Offline patraf

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Re: Java
« Reply #2 on: July 27, 2020, 23:00:50 »
Le problème ? Que ça ne marchait plus.
De guerre lasse je viens de réinstaller Java, et ça remarche, la magie c'est merveilleux !

Mais oui, dire que soit e JDK soit le JRE suffisent, et indiquer sur quoi faire pointer le jdkhome seraient pas mal.

Et préciser si Ancestris a besoin de jdkhome ou de la variable PATH ou de celles des fichiers batch que vous indiquez serait bienvenu.

Offline Zurga

  • VIP
  • Hero Member
  • *
  • Posts: 911
    • View Profile
Re: Java
« Reply #3 on: July 28, 2020, 10:48:33 »
Il y a eu une mise à jour de Java il y a quelques jours.
L'installeur d'Oracle a tendance à supprimer les anciennes versions de Java qu'il trouve.
Si vous aviez défini un chemin dans votre fichier de configuraiton ancestris.conf, il est possible qu'il ne soit plus trouvé.

Le fonctionnement de l'application est le suivant :
- Vous avez besoin d'un JRE (Java Runtime Environnement). Le JDK (Java Development Kit) n'est pas requis, mais comme le JDK inclut un JRE, cela fonctionne très bien.
- Oracle installe son JRE de manière a être reconnu par tous les programmes sur Windows (Ce n'est pas seulement une variable JAVA_HOME ou la variable PATH, il y a aussi une clé de registre, mais je ne me souviens plus laquelle exactement).
- Vous pouvez installer n'importe quelle version de Java (Celles d'Oracle, OpenJdk ou AdoptOpenJdk ou une que vous aurez compilé vous-même, si, si c'est possible).
- Si vous installer la version d'Oracle, seul le JRE 8 est libre de droits et ne nécessite pas d'enregistrement auprès d'Oracle.
- Seule la version d'Oracle est reconnue directement par les programmes et ne nécessite aucune configuration supplémentaire.
- Si vous optez pour une distribution gratuite, il faudra indiquer à Ancestris où est votre installation. Dans ce cas, dé-commentez la ligne jdkhome du fichier de configuration ancestis.conf situé dans le répertoire "etc" de votre installation d'Ancestris et mettez le chemin adéquat.
- Ancestris fonctionne avec les version 8 et supérieures de Java. Il est développé en version 8 pour une meilleure compatiblité avec le plus grand nombre. Il a été testé fonctionne l sur Java 11 et Java 14, qui sont des versions LTS (Long Term Support). Nous ne vérifions pas sur les version Short Term qui sont obsolète et non téléchargeables après 18 mois.

J'espère que ces quelques informations supplémentaires vous permettrons de mieux comprends les pré-requis relatifs à Java pour faire fonctionner Ancestris

Zurga