Author Topic: Probléme de lancement Ancestris beta (pour Mac)  (Read 94 times)

0 Members and 1 Guest are viewing this topic.

Offline stillman

  • VIP
  • Jr. Member
  • *
  • Posts: 7
    • View Profile
Probléme de lancement Ancestris beta (pour Mac)
« on: October 11, 2017, 00:10:51 »
Bonjour à tous,

Après mise à jour d'Ancestris Je rencontre un problème de lancement de la version beta d'Ancestris v 0,10 sur Mac.
J'ai un message d'erreur dans Terminal qui me signale ne pas trouver la version java 1.7.0_10 ???
Alors que j'ai la dernière version de Java.

Qu'ai je manqué et que dois je faire à votre avis.

Cordialement

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 394
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re: Probléme de lancement Ancestris beta (pour Mac)
« Reply #1 on: October 12, 2017, 05:25:07 »
Bonjour,
Il ne resterait pas une ancienne installation d'Ancestris, qui confondrait Mac? Je ne connais pas MacOS, donc peut être dis-je une bétise....
D'autre part, qu'elle est votre version de java? Dans un terminal "java -version". Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline Jean-Roger

  • VIP
  • Full Member
  • *
  • Posts: 10
    • View Profile
Re : Probléme de lancement Ancestris beta (pour Mac)
« Reply #2 on: October 12, 2017, 07:40:49 »
Bonjour à tous.


Après une erreur de manip rendant Ancestris inutilisable, j'ai fait les manips suivantes :
L'installation est fonctionnelle. Rest à voir si les pb de ralentissement observés sont résolus.
Si cette expérience peut vous servir.

Cordialement
Jean-Roger
Ancestris 0.10.0.9200
iMac mi-2011 - Intel Core I5 - 2,5 GHz - 16 Go
Mac OS X 10.13.2
Java 1.8.0_40-b27 - /Library/Java/JavaVirtualMachine/jdk1.8.0_40.jdk/Contents/Home/jre
Répertoire Utilisateur : ~/Library/Application Support/ancestris/trunk

Offline stillman

  • VIP
  • Jr. Member
  • *
  • Posts: 7
    • View Profile
Re : Probléme de lancement Ancestris beta (pour Mac)
« Reply #3 on: October 12, 2017, 23:41:55 »
J'ai déjà effectué cette procédure proposé par Jean-Roger (désinstallation, nettoyage Ancestris et dernière version Java)

Ancestris se lance avec un message d'erreur dans terminal sur la version Java et j'ai une petite fenêtre Java qui s'affiche sans aucun message.
Et impossible d'importer un gedcom.

Pour récapituler quand je tapes dans Terminal : java -version
La réponse est :
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)

Quand je tape dans Terminal : /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version
La réponse est :
java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)

Quand je tape dans Terminal : whereis java
La réponse est :
/usr/bin/java

Le chemin dans la console de paramétrage Java est : /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java

La je coince car il semble que le progamme ne trouve pas le bon chemin vers la derniére version de Java ou tout du moins je ne sais pas comment donner le bon chemin

Cordialement


Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 394
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re : Probléme de lancement Ancestris beta (pour Mac)
« Reply #4 on: October 13, 2017, 05:06:05 »
Bonjour,
Il faudrait désinstaller la version 1.6 de java pour ne laisser que la version 1.8
Peut être une solution : dans le répertoire d'ancestris, (j'ai bien dit ancestris par .ancestris/trunk), vous devez avoir dans l'arborescence :
ancestris/etc
ancestris/bin
ancestris/platform
ancestris/ancestris

il faut aller dans ancestris/etc
là vous éditez le fichier ancestris.conf, et vous décommentez la ligne jdkhome="path/to/jdk" et bien sûr vous mettez le chemin qu'il vous faut.
Celal peut fonctionner. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !