Author Topic: Photograph does not appear in tree  (Read 2470 times)

0 Members and 1 Guest are viewing this topic.

Offline Hanah

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Photograph does not appear in tree
« on: November 30, 2014, 10:14:27 »
Hi,
Sometimes a photograph, entered in Ancestris editor does not, or partly, appear in the tree. Default layer setting.

Which Operating System? : Windows,

Which version of the O.S.? : examples: Windows 7

Which version of Ancestris? :  0.8beta

What is your Java version? :  java 8.0_25-b18

What are the windows opened on your Ancestris application? :  the Treeview, the Ancestris editor, the Table view

This bug is related to the application itself

If you use the beta version, do you update Ancestris each time a new version is available? : yes

This bug appeared right after an update (you didn't get it before, and right now, you have it) : no

Which version of the module is concerned (check the "Help - About" dialog box) : example, Ancestris Core: 0.8.0.3418; for a module, example: Geo: 0.8.0.5892
Thanks.
Hanah


Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 334
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re : Photograph does not appear in tree
« Reply #1 on: November 30, 2014, 11:58:52 »
Hi,
Sometimes a photograph, entered in Ancestris editor does not, or partly, appear in the tree. Default layer setting.

I don't think it's a bug as it works like a charm here. I guess you should change the blueprint you use for the treeview. Give a try to the different blueprints available, and if you still have a problem, send a mail to the ancestris support as you run beta 0.8.
Regards, Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline Hanah

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Re: Photograph does not appear in tree
« Reply #2 on: December 07, 2014, 09:05:24 »
Bonjour François,
Thanks. As I wrote, I am on default layer setting (blue print). I had tried all and same problem for the ones with photo. I'll try the support.
Hanah

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 334
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re: Photograph does not appear in tree
« Reply #3 on: December 07, 2014, 11:18:40 »
Hi,
If you still have problems, it means the path of the pictures you want to display is not the right one. Don't forget, that :
  • all blueprints have a default links like this one :
    <prop path=INDI:SEX img=yes txt=no>
  • And the images which are displayed are presented like the way I give you below in your gedcom file :
    1 OBJE
    2 FORM gif
    2 FILE images/xxxxxxxxx.gif
Check your gedcom file, and I guess the ones which are not well displayed don't have such a path. Francois


Met ’drokfen ket evit teñzorioù va Frankiz !

Offline Hanah

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Re: Photograph does not appear in tree
« Reply #4 on: December 12, 2014, 18:09:30 »
Hi,
Thanks. I have checked. No problem in the gedcom file.
Actually some photographs appear perfectly in the Ancestris editor but not, or partly, in the tree, although tree is set with maximum zoom.
I have emailed to the support to address 'support@ancestris.org' from my email address. Will they answer at my email address or on the site ?
Hanah

Offline arvernes

  • Administrator
  • Hero Member
  • *****
  • Posts: 334
  • Pep den a dle heuilh e Donkadur
    • View Profile
    • Arvernes web site
Re: Photograph does not appear in tree
« Reply #5 on: December 14, 2014, 07:23:56 »
Hi,
Actually some photographs appear perfectly in the Ancestris editor but not, or partly, in the tree, although tree is set with maximum zoom.
If your gedcom file is not too big, you can send it to me, I will test it here to try to understand what's wrong with it.

Quote
I have emailed to the support to address 'support@ancestris.org' from my email address. Will they answer at my email address or on the site ?
I saw your mail in the support mailing list. IMHO, it's not a problem with the software, but with the way you use it, that's why I would be interested to test it here. If you have a picture wich is not well displayed, give me the ID of the appropriate individual. Francois
Met ’drokfen ket evit teñzorioù va Frankiz !

Offline Daniel

  • Administrator
  • Sr. Member
  • *****
  • Posts: 39
    • View Profile
Re: Photograph does not appear in tree
« Reply #6 on: December 19, 2014, 21:54:22 »
Hi,

The picture you joined in your email to the support effectively shows a small part of the image. This is not exactly a bug but certainely something we could improve in a later release.

In fact the blue print html code is first rendered and then clipped to fit in the tree cell, more or less like a page in a browser when you resize the window to a small dimension. In the cell you don't have scroll bar so the datas outside the cell area are not displayed.

I think you can try to update the html code to fit your needs and for instance display the image under the name. There must be some documentation about that in our web site (François?).

Also in 0.8 version you can have some popup window when you move your mouse pointer on a cell (aka tooltips). This can show more informations.

I hope these explanations will help to make it clear,

Daniel

Offline Hanah

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Re : Photograph does not appear in tree
« Reply #7 on: December 21, 2014, 10:05:56 »
Hi Daniel,
Thanks for trying to help. I am not really a specialist and am not sure I got everything clearly but will try to fix with your advise.
This site and software are great anyway and I advertize them around.
If you need me to send more information, feel free to ask.
Hanah

Offline Hanah

  • VIP
  • Jr. Member
  • *
  • Posts: 5
    • View Profile
Re: Photograph does not appear in tree
« Reply #8 on: December 28, 2014, 18:31:31 »
Hi Daniel,

After exchanging emails with François who suggested to place the picture on the left of the tree cell, and roaming and digging around Ancestris websites, I was able to figure out more precisely what you wrote in your last email.
Note that I am a real "newbie", discovering this software as well as html coding. I first wrote as a mere user.

As I could not find a way on the website to realize the plan , I tried to imagine how to do that by studying the cell blue print code. Writing the code about the picture BEFORE the text code made the picture appear on the left, which solves the problem. Improvements could be added regarding the text location in the cell, but this is beyond my abilities.

Hopefully I sent my blue print correctly to François and hope it will be possible to add it in the software.

The pop-up windows are great to but a little different in use than the tree cells. Both are interesting.

Thanks for taking interest in my question.
Hanah